Resolved
All prize details for Paediatric prizes and awards have been restored. If there is any remaining incorrect information, please report it on the website.
Identified
We're aware that Paediatrics prizes and awards are missing essential information such as deadlines, descriptions, audience tags, and award types. Prize names and URLs are not affected.